The Internet Radio Forum

A.I. Devices, Media Networks and Servers => A.I. Assistants => Topic started by: Solo2 on 19:23:40 | 08 January, 2018

Title: LMS Chromecast bridge plugin
Post by: Solo2 on 19:23:40 | 08 January, 2018
Currently, you can access BBC dash streams using the iPlayer plugin on LMS.  No need for any VPN, etc.    Add a  Google Home mini (25 USD ?) with the chromecast plugn, and you'll have a nice system with lots of options!

Never worked for me.  Chromecast bridge identifies all of the chromecast devices but LMS says no players are available.  I don't have much patience for LMS.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 06:07:52 | 09 January, 2018
That's strange - so the chromecasts are listed in the plugin?   But not then showing up as players in the lms GUI DROPDOWN menu?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 06:39:56 | 09 January, 2018
Yep.  Exactly.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 07:21:10 | 09 January, 2018
Listed in plugin after generating config file

Living Room speaker    cc:cc:42:53:c0:XX    f4350f551353792ce93fec9ac6e45d15   Living Room speaker
Speakers    cc:cc:6c:7d:00:XX    3369ee18ae2022aa92c206a150d66695   Speakers


Listed in LMS player dropdown

BLACK Radio
Living Room speaker
Speakers
TOUCH
WHITE Radio

This using  LMS 7.9.1 and plugin 0.2.12.1 static binary on a Raspi B with max2play
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 07:25:51 | 09 January, 2018
I agree that that's what it should look like, but no cigar.  Tonight I'll try uninstalling and re-installing LMS and the Chromecast Bridge and iPlayer plugins again and see if I can get any better result.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 08:51:51 | 09 January, 2018
Good luck ...
Title: Re: LMS Chromecast bridge plugin
Post by: drgeoff on 08:54:40 | 09 January, 2018
You do have the bridge running?   :)
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 09:15:27 | 09 January, 2018
You do have the bridge running?   :)

It appeared to be running properly, but apparently it isn't.  It installed without problems.  I'll start over again when I get home.
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 11:39:39 | 09 January, 2018
Listed in plugin after generating config file

Living Room speaker    cc:cc:42:53:c0:XX    f4350f551353792ce93fec9ac6e45d15   Living Room speaker
Speakers    cc:cc:6c:7d:00:XX    3369ee18ae2022aa92c206a150d66695   Speakers


Listed in LMS player dropdown

BLACK Radio
Living Room speaker
Speakers
TOUCH
WHITE Radio

This using  LMS 7.9.1 and plugin 0.2.12.1 static binary on a Raspi B with max2play


Listed in plug in config file:

List of players currently in configuration file - Note that more devices might have been discovered

         
   Basement chromecast    cc:cc:33:fb:41:xx    a83540ccb25275593e8fd2767b2f59ee   Basement chromecast
   Bedroom chromecast    cc:cc:33:f3:31:xx    a379ee8c2e99ed2e01bd99c232a7e86b   Bedroom chromecast
   Guestroom chromecast    cc:cc:33:fb:42:xx    fa0c70e7f292dabc38806e966bfa402c   Guestroom chromecast
   Home group    cc:cc:f4:f4:e7:xx    04b7962b-294e-4ac6-b556-7bffc72f3715   Home group
   Mondo plus    cc:cc:4d:56:a0:xx    31acdb36b21ef4bf64098684a318fcb3   Mondo plus
   Bedroom speaker    cc:cc:42:15:eb:xx    e5a5e1951a802dcb66192ac2000c1628   Bedroom speaker
   Encore plus    cc:cc:fd:18:d9:xx    eb1144ade00dbc7da8f634bf38904f6b   Encore plus
   Living room chromecast    cc:cc:33:f4:cd:xx    520f145e519b4f74ba83f87461fadda5   Living room chromecast
   Living Room speaker    cc:cc:42:47:15xx    59d608f9b6b0fc1372e327cd92b61f6a   Living Room speaker

Listed at LMS player drop down:

Choose player  Your player was not found.

Same version of LMS and Chromecast bridge plugin as mentioned.  Windows 10 pro desktop.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 12:16:25 | 09 January, 2018
On the plugin page

There is a setting for each device to enable - if you use the common parameter for all players they will all be enabled.   If each player has its own settings you could check to see if they are all enabled.

Other than that, I'm not sure why no players are listed!   

Have you posted on the chromecast plugin thread at slimdevices?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 15:05:32 | 09 January, 2018
On the plugin page

There is a setting for each device to enable - if you use the common parameter for all players they will all be enabled.   If each player has its own settings you could check to see if they are all enabled.

Other than that, I'm not sure why no players are listed!   

Have you posted on the chromecast plugin thread at slimdevices?

Common parameter is shown.  I experimented by entering the Mondo Plus instead of common parameter.  Still no players found.  Either I'm overlooking something that should be obvious or else it just doesn't work.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 15:42:59 | 09 January, 2018
You have so many players/devices that it's difficult to know where to start!

I assume that there's a real chromecast audio in the list?   A pain but you could disable all the others so you have just one enabled - what happens then.   

I assume that you have actually switched the plugin ON - first check-box then hit Apply ?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 16:24:00 | 09 January, 2018
Yes the plugin is on and now lms is recognizing the players.  The players seem to be receiving, but there is no sound.  Any thoughts on that?

The are 3 chromecast audios, 2 google home minis, the Encore Plus with chromecast built-in and the Mondo Plus.  It sort of grew like topsy.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 16:43:51 | 09 January, 2018
Hmm?  No sound?  Need to investigate that ... will get back to you.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 16:54:50 | 09 January, 2018
What is listed in plugin codecs?

I have

pcm,aif,flc,mp3
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 17:02:17 | 09 January, 2018
Found this:

[edit 2016-01-23]: under Windows, if everything seems to work but you have no sound, you *must* add a firewall rule authorizing squeeze2cast-win.exe or go into C:\ProgramData\Squeezebox\Cache\InstalledPlugins\P lugins\CastBridge and launch *once* squeezecast-win.exe where you'll be prompted for authorization
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 17:19:45 | 09 January, 2018
Attempted that.  No joy.  Turning the firewall off altogether didn't help.
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 17:45:50 | 09 January, 2018
Ok, some success.  I went to c:\ProgramData . . .\Plugins and clicked on squeeze2cast-win.exe, and added it as an exception to the firewall.  I got sound;  local content plays on all the chromecast devices very well.  I was able to get the non-UK BBC channels to play, but with much buffering.  Thanks!

Edit:  After a while, the buffering seemed to correct itself.  BBC 3 in the m3U8 HLS sounds great on the Encore Plus!  Then, sadly, after a few minutes, the streams seem to peter out and die.  So, a great idea, but a lot of work for 3 minutes of music.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 01:15:15 | 10 January, 2018
What version of BBC iplayer plugin do you have?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 03:53:17 | 10 January, 2018
What version of BBC iplayer plugin do you have?

Triode v1.5.4.5  Is there a better one?  Thanks.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 05:57:01 | 10 January, 2018
No - that's the latest.  Have you tried in the iplayer settings to set it to DASH only?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 06:24:44 | 10 January, 2018
Tried it on DASH, only.  It buffers, plays for 3 seconds, buffers, plays for 3 minutes, then the stream ends.  I'll try setting the buffer on the Mondo Plus to "large" to see if that makes any difference.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 06:32:53 | 10 January, 2018
What happens with the other chromecasts ?  Same effect?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 06:54:22 | 10 January, 2018
Same.  Buffers, plays for a few seconds, buffers again, plays again, stream ends.  I note that the counter on the player gets up to about a minute and 20 seconds, then goes back to zero.  It does that repeatedly, about 5 times, then quits.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 07:02:39 | 10 January, 2018
... and it's the same for other radio streams?

What codecs do you have in the castbridge plugin?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 10:38:11 | 10 January, 2018
... and it's the same for other radio streams?

What codecs do you have in the castbridge plugin?

No, other radio streams are fine (I'm now playing WKSU, the local NPR station, via castbridge).  It's only the BBC stations via the iPlayer plugin that fail.

I have pcm.aif.flc.mp3 in the castbridge plugin.
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 10:59:56 | 10 January, 2018
When I look at the server log, it shows this:

 Plugins::BBCiPlayer::DASH::__ANON__ (779) Chunk fetch status 200 Long chunk fetch time 2292   800
[18-01-10 13:57:24.3098] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -14 streamtime=1515610675
[18-01-10 13:57:24.3104] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -14 streamtime=1515610675
[18-01-10 13:57:24.3728] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -14 streamtime=1515610675
[18-01-10 13:57:24.3737] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -14 streamtime=1515610675
[18-01-10 13:57:24.4311] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -14 streamtime=1515610675
[18-01-10 13:57:24.4325] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -14 streamtime=1515610675
[18-01-10 13:57:24.4332] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -14 streamtime=1515610675
[18-01-10 13:57:29.3733] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -15 streamtime=1515610681
[18-01-10 13:57:29.3739] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -15 streamtime=1515610681
[18-01-10 13:57:34.4479] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -10 streamtime=1515610681
[18-01-10 13:57:34.4486] Plugins::BBCiPlayer::iPlayer::getMetadataFor (567)  Invalid estimated delay -10 streamtime=1515610681
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 11:01:20 | 10 January, 2018
Thanks.  I'll ask the iplayer guy for help!
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 11:04:30 | 10 January, 2018
Thanks.  FWIW, the BBC iPlayer plugin server settings show "seconds to delay start live stream" 15 secs. and "buffer fullness threshold" 255.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 11:58:11 | 10 January, 2018
Those settings are the same as mine.

Another query:  do you run anything like Hitmanpro Alert anti-ransomware ?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 12:00:57 | 10 January, 2018
Goodness, no.  Just the Windows Defender stuff that can't be gotten rid of.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 12:04:46 | 10 January, 2018
Okay - somebody reported similar problem ....

later
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 12:09:15 | 10 January, 2018
Ok, thanks for helping!
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 12:18:01 | 10 January, 2018
I note here http://forums.slimdevices.com/showthread.php?104654-LMS-keeps-buffering-since-latest-iplayer-fix-and-oppo-bdp105-installation that the iplayer app will re-buffer when there is a lot of network traffic and plugin author suggests pulling the plug on LMS's UPnP media server plugin to reduce this traffic.  I do have that plugin running, so when I get home I will disable it to see if that makes a difference.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 12:30:57 | 10 January, 2018
Yes - disable the UPNP plugin.

More feedback from the iplayer author:

Quick test would be to set "delay to start live stream" to 5 min.


What type of system - OS, processor , memory etc
Is the user in the UK (or appears to be in UK - faster UK streams can cause problem if not in UK)
What are the BBCiPlayer settings ?


He also says:

The error below means that BBC replied with a requested chunk after 2292 seconds - 38 minutes !! what is going on

Plugins::BBCiPlayer:ASH::__ANON__ (779) Chunk fetch status 200 Long chunk fetch time 2292 800

Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 12:59:25 | 10 January, 2018
Ok.  When I return, I'll disable the UPnP plugin and set the delay thingy to 5 minutes.  I changed the iPlayer plugin settings to DASH, only as per your suggestion, and the rest of the settings are at the default.  I'm in the USA and have been trying to play only the stations labeled "non UK." 

This is a Windows10Pro 64-bit desktop, with an AMD PhenomII x945 processor running at 3 GHz, with 8 GB of RAM.  As far as the 38 minute problem goes, I guess my response is, "yes sir."
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 13:35:07 | 10 January, 2018
player dev says he thinks it's a chromecast issue - so back to the beginning!

Try disabling the upnp plugin.
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 14:00:54 | 10 January, 2018
If it were a chromecast issue, wouldn't I have problems playing non-BBC channels?  I don't know.  I'll turn off the UPnP plugin.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 14:41:15 | 10 January, 2018
No - he means there's an issue with chromecast and iplayer.   There used to be some issue but I thought it was fixed.  Which castbridge version do you have?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 14:59:57 | 10 January, 2018
Chromecast Bridge v0.2.12.1.  I set the delay gizmo to 5 minutes and un-enabled the UPnP plug in and BBC 3 seems to be working without the buffering and dropouts.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 15:11:15 | 10 January, 2018
So, I just tried BBC Radio 5 live ... no issues.  It reports the stream as Bitrate: 96kbps CBR (Converted to 1411kbps PCM)

Puzzled.

Just seen your latest - still puzzled!

So would you say it's working okay now?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 15:17:35 | 10 January, 2018
Well, fingers crossed, as they might say at the BBC.  Obviously, it takes several minutes for the streams to start, but once they get going, they seem to keep going.  The player reports "4 mins delay from BBC 3."  The audio quality is very good.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 15:36:21 | 10 January, 2018
Try setting the value back to default.  Maybe he culprit was/is upnp.

On another tack:  have you tried Google Play Music with uploaded tracks?   Does it work for you - there are 100s of complaints on the Google forum that it's broken (including me).   I'm referring to the mini itself.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 15:40:37 | 10 January, 2018
Castbridge dev suggests:

Check that pacing_size is more than 1M and if it's still 1M, reduce it to 500k.
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 15:44:32 | 10 January, 2018
Castbridge dev suggests:

Check that pacing_size is more than 1M and if it's still 1M, reduce it to 500k.

Where the heck does one find pacing_size?
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 15:46:14 | 10 January, 2018
Try setting the value back to default.  Maybe he culprit was/is upnp.

I tried disabling the UPnP plugin first, and had no luck.  Then I changed the delay thingy to 5 minutes and it worked.
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 07:32:33 | 12 January, 2018
I will say, though, that the BBC iPlayer-Castbridge setup is extremely vulnerable to network traffic.  If I have it running, and my wi-fi connected cell phone rings or gets a notification, the whole thing falls over.  I'll grant that my network probably has a lot more stuff going on than most so maybe it's just me.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 08:36:03 | 12 January, 2018
I suspect it's something more to do with the Googles.  I have noticed internet disconnects since the googles were added to my network.   Goodness knows what the Google presence is actually doing on a network ...
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 08:56:24 | 12 January, 2018
They're probably listening intently for a "meow"  and phoning home so Google can then send me 8 ads for kitty litter.
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 15:08:52 | 12 January, 2018
Do you use Spotify?  There's a Spotty plugin ...
Title: Re: LMS Chromecast bridge plugin
Post by: castalla on 15:50:32 | 12 January, 2018
See this:

https://productforums.google.com/forum/#!topic/googlehome/lssgm7TjgGs;context-place=forum/googlehome
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 17:49:19 | 12 January, 2018
Do you use Spotify?  There's a Spotty plugin ...

Yes, but I already can get Spotify by yelling at the minis, telling them to cast it to the Mondo Plus or Encore Plus.  I can use the Spotify phone and tablet apps to cast it to the chromecasts so it will play on the powered speakers or use Spotify Connect to listen to it on the receivers.  So that seems like quite enough ways to get the ubiquitous Spotify and adding it to LMS would be a little superfluous. It is nice to know, though, that LMS has such an active cadre of developers.

Also, unless Grace Digital has given up, Spotify Connect is supposed to show up on the Mondo and Encore Plus, which is yet another way of getting Spotify.
Title: Re: LMS Chromecast bridge plugin
Post by: Solo2 on 17:50:21 | 12 January, 2018
See this:

https://productforums.google.com/forum/#!topic/googlehome/lssgm7TjgGs;context-place=forum/googlehome

Thanks.  The exactly describes what I was mentioning.  I hope they do something about it!