Author Topic: Tangent Quattro MKii stuck at "Starting..."  (Read 1763 times)

nicoledb

  • Newbie
  • *
  • Posts: 3
  • Country: 00
Tangent Quattro MKii stuck at "Starting..."
« on: 16:34:52 | 30 June, 2017 »
I recently got a Tangent Quattro MKii from an acquaintance who hasn’t used it for a while. However, when trying to power up this radio, after the message “Reciva enabled / ARM powered” the display shows “Starting…” and then the radio will be stuck there. Any idea how I can resolve this? I’ve already tried a Factory Reset (unplug, wait, press Select and replug), but that didn’t help.
Reciva Tangent Quattro MK2
Silicon Frontier Oxx Classic

drgeoff

  • Hero Member
  • *****
  • Posts: 853
  • Thanked: 32 times
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #1 on: 01:21:40 | 01 July, 2017 »
Did you keep holding the Select button down while plugging power back in and keep holding it? Did it reach 'Factory reset complete' or did anything different from the usual failure to start happen?

That reset method is only present in later firmwares, probably not in any of the 'official' ones that would be present in the Quattro unless a request had been made to Reciva for it to have the 'legacy enhanced firmware' aka the 'beta firmware' or later firmware had been loaded via the Sharpfin route.

Where in the world are you? Are you sufficiently competent to open the radio and unplug internal components?
The following users thanked this post: nicoledb

nicoledb

  • Newbie
  • *
  • Posts: 3
  • Country: 00
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #2 on: 12:28:30 | 01 July, 2017 »
Yes, I kept holding the Select button until the display showed "Factory reset complete" but then the radio would be stuck there. Unplugging and replugging resulted in being stuck at "Starting..." again.

According to a note from the previous owner, the original firmware was v257-a-421-a-041. Not sure if he tried to update after that, but from the radio being stuck I suspect he unsuccesfully tried to update the firmware. And obviously I can't check the current firmware since the radio will not start :-(.

I'm in The Netherlands. Yes, I would be comfortable opening the radio (I'm an electrical engineer), but I'm afraid I would need reasonably detailed instructions on what to do. I've tried to read up on Sharpfin, but I'm not sure I completely understand how to do that. Of course, if someone can convince me that it's likely to solve this problem I'd happy to dive into it!
Reciva Tangent Quattro MK2
Silicon Frontier Oxx Classic

drgeoff

  • Hero Member
  • *****
  • Posts: 853
  • Thanked: 32 times
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #3 on: 16:33:40 | 01 July, 2017 »
I've sent you a message.

Graggie

  • Newbie
  • *
  • Posts: 1
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #4 on: 13:05:28 | 26 December, 2017 »
Our Tangent Quattro shows black squares when we plug it in. It isn´t connecting to our network or reacts to any button. Any advice? Thank you!

Radiogaga

  • Newbie
  • *
  • Posts: 3
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #5 on: 12:50:09 | 06 January, 2019 »
Hi there,
Since a few Years I‘m using the Tangent Quattro MKII.  :)
After a disconnection from Mains and back to mains I got the the same Problem like nicoledb.
I got the information to Plug and unplug a few times the radio. But no success .
I pressed the select button and Plugged Mains. Factory reset was successfuly. But also no success. :(
Due to my 9 years old son is listening „Kinderradio“ (children Radio) to fall in sleep every Night he is very unhappy at the moment, cause he has Bad minds in his head.
Hope to get a soloution in this Forum to Save this great Radio.


drgeoff

  • Hero Member
  • *****
  • Posts: 853
  • Thanked: 32 times
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #6 on: 04:13:58 | 07 January, 2019 »
Hi there,
Since a few Years I‘m using the Tangent Quattro MKII.  :)
After a disconnection from Mains and back to mains I got the the same Problem like nicoledb.
I got the information to Plug and unplug a few times the radio. But no success .
I pressed the select button and Plugged Mains. Factory reset was successfuly. But also no success. :(
Due to my 9 years old son is listening „Kinderradio“ (children Radio) to fall in sleep every Night he is very unhappy at the moment, cause he has Bad minds in his head.
Hope to get a soloution in this Forum to Save this great Radio.
Some possibilities:

1.  Corrupted firmware on Barracuda module
2.  Faulty Wi-Fi module
3.  Hardware fault on Barracuda module
4.  Other

Are you sufficiently competent and confident to open the radio and unplug the USB Wi-Fi module?

Radiogaga

  • Newbie
  • *
  • Posts: 3
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #7 on: 06:04:29 | 07 January, 2019 »
Hi Drgeoff,
Thanks for the quick response.
I already opened the radio and I have disconnected the WI-Fi module which is only connected via USB
I tried to start the Radio without the WiFi-Module, but then I only got the black squares in the Display. I connected it again and got still the same starting problem.
So the opening of the radio is no problem for me. I´m a TV repair technician.
I also tried another Power supplyl, cause I thought that the capacitor is faulty and that there is ripple voltage on the 12V which causes the starting problem.
Is it possible to reload the firmware on the Barracuda module or is it possible to repair a such a faulty module?
Thanks in advance.

drgeoff

  • Hero Member
  • *****
  • Posts: 853
  • Thanked: 32 times
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #8 on: 09:23:46 | 07 January, 2019 »
It is possible to flash the firmware - see 'JTAG.pdf' in the post http://iradioforum.net/forum/index.php?topic=193.0 - but it is a far from simple procedure.  I have done it a few times myself and am the author of 'Barracuda Connector.pdf' in that same post. (The download links in that post are out of date - change the recivarefuge.net part to iradioforum.net.)

If a reflash does not help then there is probably a hardware fault on the module.  I do have not absolute proof but suspect that one or more of the BGA solder joints between the Samsung CPU chip and the board goes bad.  Sometimes application of freezer spray or a hot air gun can temporarily bring a module back to life.  It's worth trying that before reflashing because if the radio does work again, no matter how briefly, it means the firmware is OK and reflashing will gain you nothing.  I no longer attempt to repair modules with a hardware fault unless it is visually obvious. 
« Last Edit: 09:29:16 | 07 January, 2019 by drgeoff »
The following users thanked this post: Alan E Hill

Radiogaga

  • Newbie
  • *
  • Posts: 3
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #9 on: 01:20:44 | 10 January, 2019 »
thanks, I will try it  ;)

Alan E Hill

  • Oh! That British Bloke ...
  • Administrator
  • Hero Member
  • *****
  • Posts: 2336
  • Country: gb
  • Thanked: 45 times
  • That British Bloke ...
    • Oh! That British Bloke ...
Re: Tangent Quattro MKii stuck at "Starting..."
« Reply #10 on: 02:07:37 | 11 January, 2019 »
...The download links in that post are out of date

Fixed. Thanks for drawing it to my attention.

http://iradioforum.net/forum/index.php?topic=193.0
Alan | That British Bloke Listening in Navarumsunk, NJ, USA, where all the women are strong, all the men good-looking, and all the children above average
Listening to LiquidLounge
Sangean WFR-20 / RCR-8 | Grace IR2600 | Alexa
dumnonia.us