Author Topic: Problem connecting to Sirius [solved]  (Read 720 times)


  • Newbie
  • *
  • Posts: 1
Problem connecting to Sirius [solved]
« on: 16:03:44 | 31 August, 2018 »
I wanted to share something that might be of help to some of you with the Grace Digital Radio "Mondo". I don't know if mine's a "plus" or not (it's a 6001 model) but it had been working fine with Sirius for quite some time and then recently stopped and every time I tried to update the userid and password for the login to Sirius so we could use the streaming service, I got an "authentication failure".

I worked on this for hours with no luck. I had recently updated to 146.115 - the latest as of 14AUG18. I don't necessarily think that was at fault because the problem existed prior to that update but the update didn't fix it. I had tried the factory reset through the menu system and that didn't help.

So, somewhere on this forum, I saw where you can also force a factory reset by removing the power, holding down the snooze button, reapplying power and then waiting (while holding the snooze button down still) for the factor reset message to appear. I tried this and it seemed to reset just like it had when I tried it off the menu system. However, this time when I entered my userID and password, the connection to Sirius worked! I had literally tried dozens of times prior to that with the same authentication failure every time.

So, I don't know if this is any kind of genuine fix for that problem but if you are having trouble connecting to the streaming service from Sirius with the Mondo and if you are otherwise able to connect to the streaming service (like with your phone or laptop), perhaps this approach might help you. Since it took me hours to find a solution that worked, I wanted to pass it along for whatever it might be worth.

Hope this helps someone with the same issue.

Kind regards,