Author Topic: Grace model ITC -IC1000B connects to stations but no audio  (Read 288 times)

Airwaves

  • Newbie
  • *
  • Posts: 3
Hello:  I was given this radio several years ago and until recently it has been performing well with the occasional "error" message showing up on the screen.  This sort of thing was easily corrected by pulling the plug and plugging it back in after 30 seconds or so. 

It now presents a new annoying problem:  it shows a connection to a station but there is no audio.  Initially the audio would suddenly come on after several minutes.  I sent an email to the Grace technical staff and was told it would appear to be a glitch with communication between the radio and modem and I should disconnect the modem and re-connect it after a short wait.  This was done but it did not resolve the issue. Today, no audio came on after waiting 15 minutes so I did a factory default, re-set everything, made a network connection, called up a station and although it connected to the station, still no audio.  I have another interest radio in the bedroom (not a Grace) and it works without any trouble.  I suspect a component is going (or has already gone??? Grace says this is most unlikely.

Has any other users experienced such a problem?

Thanks


Solo2

  • Administrator
  • Hero Member
  • *****
  • Posts: 2381
  • Country: us
  • Thanked: 89 times
  • On the internet, no one knows whose dog you are.
Re: Grace model ITC -IC1000B connects to stations but no audio
« Reply #1 on: 19:48:40 | 12 April, 2019 »
It has reached a ripe old age.  I hate to suggest it,  but I think it has passed on
Radios:   Grace GDI-IRA500, 2 GDI-IRDT200s, GDI-IRMS300, Grace IRC6000W, Grace GDI-WHA6001, Grace and Reciva iradio apps

Airwaves

  • Newbie
  • *
  • Posts: 3
Re: Grace model ITC -IC1000B connects to stations but no audio
« Reply #2 on: 05:09:18 | 13 April, 2019 »
Hello Solo2:  Thank you for the prompt response.  I guess I suspected as much but thought it may be a bad capacitor or some other "simple" component.  I could handle replacing that but am not good with IC components, etc.

I will send it on it's way.

Solo2

  • Administrator
  • Hero Member
  • *****
  • Posts: 2381
  • Country: us
  • Thanked: 89 times
  • On the internet, no one knows whose dog you are.
Re: Grace model ITC -IC1000B connects to stations but no audio
« Reply #3 on: 13:16:57 | 13 April, 2019 »
Grace won't try to repair that model as they can no longer get parts.  They offer a 30% discount on new radios under those circumstances but I don't believe that they ship to Canada (maybe you know somebody in the US?).  You may want to call them anyway and see if they will do anything to help.



 Parts are extremely limited for IRC models at this point-so it's important to ask if we can repair your radio.

If you need a discount coupon for an upgraded plus model radio, use coupon code UPGRADE30 at gracedigital.com
Radios:   Grace GDI-IRA500, 2 GDI-IRDT200s, GDI-IRMS300, Grace IRC6000W, Grace GDI-WHA6001, Grace and Reciva iradio apps

bob12564

  • Jr. Member
  • **
  • Posts: 13
  • Thanked: 3 times
Re: Grace model ITC -IC1000B connects to stations but no audio
« Reply #4 on: 08:37:41 | 21 April, 2019 »
Two of my older Grace Digital radios have also developed problems, mainly with the knobs.  One needed a new WiFi dongle.  I agree with Solo2 that parts might be scarce for older models.  You also have to consider the cost of shipping and the cost of repairs and parts.  I know this is probably sacrilege on this forum, but a cheaper option is to look at smart speakers from Google and Amazon.  They can handle most of the functions of an internet radio and provide other services as well.  They're often on sale.  Pricier models include display screens.  There's a thread on these devices elsewhere on this forum. 

Airwaves

  • Newbie
  • *
  • Posts: 3
Re: Grace model ITC -IC1000B connects to stations but no audio
« Reply #5 on: 13:53:07 | 14 May, 2019 »
As an aside to this topic, I apologize for not replying sooner but I forgot my password and then had trouble attempting to establish a new one to return to the forum.

For the possible benefit of others who may also have an older Grace model such as this, I took the plunge as I had nothing to lose (other than the radio) and checked the printed circuit boards on the unit.  I discovered three "cold" solder joints (one barely connecting to a pin on the processor).  I touched up these areas powered up the unit.  I could not believe the results.  Ever since new, it would take up to 30 seconds to receive a station and now the maximum wait is about 2 seconds!  It works better than new.  I'm happy to retain the radio.

Solo2

  • Administrator
  • Hero Member
  • *****
  • Posts: 2381
  • Country: us
  • Thanked: 89 times
  • On the internet, no one knows whose dog you are.
Re: Grace model ITC -IC1000B connects to stations but no audio
« Reply #6 on: 13:59:46 | 14 May, 2019 »
Glad I was wrong!
Radios:   Grace GDI-IRA500, 2 GDI-IRDT200s, GDI-IRMS300, Grace IRC6000W, Grace GDI-WHA6001, Grace and Reciva iradio apps

Dogmatix

  • Hero Member
  • *****
  • Posts: 1281
  • Country: de
  • Thanked: 69 times
Re: Grace model ITC -IC1000B connects to stations but no audio
« Reply #7 on: 23:25:36 | 14 May, 2019 »
I know this is probably sacrilege on this forum, but a cheaper option is to look at smart speakers from Google and Amazon.

Infamy! Infamy!
Radios in use: Roberts Stream 93i & SB1 (×2),  Revo Pixis RX, Hama DIT2010, IR110 & DIR3500, Technisat 520, Sangean WFR-29C.

 

anything